How to fix: « Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed »

Logo Docker

Message d’erreur:

« Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed »

Problem: package docker

 

Solution:

Pour résoudre ce problème, il est nécessaire de forcer l’installation en mode manuel du paquet containerd.io.

Vous trouverez tous les paquets rpm sur le site officiel de Docker.

yum install -y https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm
 
Une fois que le paquet containerd.io est installé, vous pouvez procéder à l’installation de Docker avec la commande dnf ou yum :
dnf install docker-ce docker-ce-cli containerd.io
 
Note:
Vous pouvez vérifier la version de Docker avec la commande suivante:
docker -v
 
Une fois que docker est installé avec succès, vous pouvez lancer Docker :
 
systemctl start docker
Et enfin cette commande pour vérifier que Docker Engine est correctement installé et fonctionne normalement :
 
docker run hello-world
Share

PowerShell sur Linux : pourquoi et comment ?

Auteur & Source : Pascal Sauliere (bio)

J’ai eu le plaisir de présenter cette semaine un sujet sur PowerShell sur Linux, pour le French PowerShell User Group (FrPSUG), que je remercie chaudement pour l’invitation. La présentation se trouve dans le GitHub du FrPSUG et ici même :

2017-04-11 FRPSUG PowerShell sur Linux

La présentation a eu lieu en ligne grâce à Skype for Business et a été enregistrée :

Toutes les démos de la présentation sont issues du GitHub de PowerShell, dans le répertoire “demos” :

https://github.com/PowerShell/PowerShell

Ce dépôt GitHub contient également, outre les sources de PowerShell, les documentation d’installation pour Windows, Linux, MacOS et Docker.

Share