How to fix: « Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed »

Logo Docker

Message d’erreur:

« Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed »

Problem: package docker

 

Solution:

Pour résoudre ce problème, il est nécessaire de forcer l’installation en mode manuel du paquet containerd.io.

Vous trouverez tous les paquets rpm sur le site officiel de Docker.

yum install -y https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm
 
Une fois que le paquet containerd.io est installé, vous pouvez procéder à l’installation de Docker avec la commande dnf ou yum :
dnf install docker-ce docker-ce-cli containerd.io
 
Note:
Vous pouvez vérifier la version de Docker avec la commande suivante:
docker -v
 
Une fois que docker est installé avec succès, vous pouvez lancer Docker :
 
systemctl start docker
Et enfin cette commande pour vérifier que Docker Engine est correctement installé et fonctionne normalement :
 
docker run hello-world
Share

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.